Quantcast

EWS Settings Template Not Found Error

FAQ000235670

19 May 2022

Issue

When navigating to the EWS Login (Settings \ Integrations \ EWS Login) you get an error like below indicating that the EWS Settings Template cannot be found.

 

Example of EWS Settings Template Not Found Error

Product Line

Power Monitoring Expert

 

Environment

Power Monitoring Expert 2021

 

Cause

Due to an unforeseen issue this can occur after an upgrade to PME 2021 from a previous version of PME. If you navigate to the following folder - C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\Applications\EWS\Content\Configuration - you can see that the template is indeed in that folder.

 

The issue is that EWS has been disabled in the web.config file and you need to re-enable it.

 

Resolution

To re-enable EWS in the web.config file please do the following:

 

1. On the PME server, open the web.config file for editing, for example in Notepad. You can find this file in ...\Power Monitoring Expert\applications\EWS

 

2. Search for the <add key="EWSEnabled" element in the file.

 

3. The value for EWSEnabled will be set to “NULL” instead of “0” or “1”. Change the value to "1".

 

4. Save the web.config file and close it.

 

Refresh your PME and the EWS Login page will now be displayed correctly when navigating to it.