Cannot open database requested by the login. The login failed. Login failed for user 'ION'.

FA210038

31/07/2020

Issue
The System Log Events in Management Console is populated with one or more of the following errors:

Timestamp
Priority
Source
Category
Description
8/1/2012 1:04:24 PM 191 ReportView_PQWorstDisturbance Reporting View Cannot open database "ION_Data_archive" requested by the login. The login failed. Login failed for user 'ION'.
8/1/2012 1:04:23 PM 191 ReportView_PQIncidentData Reporting View Cannot open database "ION_Data_archive" requested by the login. The login failed. Login failed for user 'ION'.
8/1/2012 1:04:23 PM 191 ReportView_SourceListArgumentDescription Reporting View Cannot open database "ION_Data_archive" requested by the login. The login failed. Login failed for user 'ION'.
8/1/2012 1:01:23 PM 191 ReportView_LoadProfile Reporting View Cannot open database "ION_Data_archive" requested by the login. The login failed. Login failed for user 'ION'.
8/1/2012 1:01:23 PM 191 ReportView_LoadProfileSummary Reporting View Cannot open database "ION_Data_archive" requested by the login. The login failed. Login failed for user 'ION'.
8/1/2012 1:00:49 PM 191 ReportView_SourceListArgumentDescription Reporting View Cannot open database "ION_Data_archive" requested by the login. The login failed. Login failed for user 'ION'.
8/1/2012 1:00:49 PM 191 ReportView_ShiftEnergy Reporting View Cannot open database "ION_Data_archive" requested by the login. The login failed. Login failed for user 'ION'.
7/30/2012 1:07:54 PM 191 ReportView_PeriodOverPeriod Reporting View Cannot open database "ION_Data_archive" requested by the login. The login failed. Login failed for user 'ION'.
7/25/2012 5:58:05 PM 191 ReportView_LoadProfileSummary Reporting View Cannot open database "ION_Data_archive" requested by the login. The login failed. Login failed for user 'ION'.
7/25/2012 5:58:05 PM 191 ReportView_LoadProfile Reporting View Cannot open database "ION_Data_archive" requested by the login. The login failed. Login failed for user 'ION'.
7/25/2012 1:14:12 PM 191 ReportView_PeriodOverPeriod Reporting View Cannot open database "ION_Data_archive" requested by the login. The login failed. Login failed for user 'ION'.

Product Line
Power Monitoring Expert 9.0
Power Monitoring Expert 8.x
Power Monitoring Expert 7.2.2

Environment
Management Console, System Log Events

Cause
It may be that the archive database was once selected in Reporting Configuration Manager, but even after removing it a reference still remains in the database. Another possibility is that ION_Data_archive, which was once created by the archiving process, is neither attached in SSMS, nor selected in 'Reporting Configuration Manager'. There are no subscriptions for this database either. Also, in Reporting Configuration Manager, if ION_Database is selected as the main database in which reports run against, the web reports will be generated correctly against ION_Data.

Resolution
In order to fix the problem:

1. Open ION_Network > dbo.CFG_ItemValue table
2. Find the row with ItemID = 5; this row refers to 'ItemName = DatabaseIdentifier'
3. Set the 'Value' column to 'ION_Database'

Web reports run against the selection in Reporting Configuration Manager and ION_Network database entry is not a necessary criteria for the reports to run against the selected database.