Discover our Clipsal Smart Home packages as seen on the Block

in location

OR

I'm looking for

  • Wholesalers
    • Uncheck All Check All
  • EXPERTISE
    • Expand
    • Expand
    • Expand
    • Uncheck All Check All
  • Switchboard Manufacturers
    • Uncheck All Check All
OR

The best way to see what Clipsal electric products can do for your home is seeing them in action at a Clipsal Display Centre.

Product stock may vary according to location. If you're after a specific product range, please check with your chosen location before visiting.

10 Results
    Load More Load Complete
    Change Location

    Power Monitoring Expert 8.x/9.0 - Some of the ION services will not start - 'Error 1053 - The service did not respond to the start or control request in a timely fashion'

    Issue
    In some environments, some of the ION services will fail to start, either after reboot or when restarted manually. The affected services by software version are:

    Power Monitoring Expert 9.0
    • ION Application Modules Core Services Host
    • ION Cloud Agent Service
    • ION Managed Circuit Service
    • ION Diagnostic and Usage Service
    • ION Log Subsystem Router Service
    • ION Software Data Processing Service
    • ION Software Modbus Gateway Service
    Power Monitoring Expert 8.x 
     
    • Application Modules CoreServicesHost
    • ION Diagnostic and Usage Service
    • ION Managed Circuit Service
    • ION Software Alarm Service
    • ION Software Modbus Gateway Service
       
    You will see a popup error that states:
    'Windows could not start the ION service on Local Computer.
    Error 1053: The service did not respond to the start or control request in a timely fashion'

    Product Line
    Power Monitoring Expert 8.x
    Power Monitoring Expert 9.0

    Environment
    At this time, it is not entirely clear why this only happens in some systems. It seems to correlate to some Windows Updates.

    Cause
    When signed .Net service executables start, an attempt is made to verify the digital signature. If this attempt takes longer than 30 seconds, the Windows Service Control Manager (SCM) does not allow the service to start, and you will see the error described above. It was recommended by Microsoft that this check be disabled prior to .Net Framework 4 and later via a setting in the service's config file, which is what was done in the older ION services. Microsoft stated that this was unnecessary when using the .Net framework 4.0 and later, so newer ION services did not include this element in the config files.

    See this link for more information:
    https://docs.microsoft.com/en-us/dotnet/framework/configure-apps/file-schema/runtime/generatepublisherevidence-element

    In spite of what is said in the link above, it now seems that in some environments this config element is still necessary.

    Resolution
    This problem can be easily resolved by adding the element below to the affected ION service config file. Updated files are attached. There is a package for PME 8.2, and also for PME 9.0.


       
           
       



    Note that the ION Diagnostic and Usage Service and ION Software Modbus Gateway Service do not have .config files, so they need to be added.
    The required files are attached. There is a package for PME 8.2, and also for PME 9.0.

    Deployment Instructions
    Be sure to stop all ION services before deploying!
    Extract the zip file corresponding to your PME version and copy these files and their folders into the Power Monitoring Expert directory, replacing the existing files. 


     

    Didn’t find what you were looking for?

    Try Searching Again View Our Categories

    Need further assistance?

    Our Customer Care department provides total customer service solutions for our residential, industrial and commercial applications.

    Get Assistance