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    PMEv8.0 Trends error - You are not authorized to view this application

    Issue 
    Launching Trends in PMEv8.0 causes error "You are not authorized to view this application" when using SSL (https://servername/Web)

    Product Line 
    Power Monitoring Expert PMEv8.0

    Environment 
    Web Applications

    Cause 
    Launching Trends in PMEv8.0 causes error "You are not authorized to view this application" when using SSL (https://servername/Web)

    Resolution 
    *Warning: Take backups of any files prior to modifying them. Ensure the backups are in a location that will not be overwritten (i.e. the Desktop).

    This error will only be seen if using SSL (https://servername/Web). 
    Workaround 1: If SSL Server certificate already exist

    Navigate to SSL server certificate to get key value:
    1) Click on the Start menu, go to Administrative Tools, and click on Internet Information Services (IIS) Manager. 
    2) Click on the name of the server in the Connections column on the left. Double-click on Server Certificates. 
    3) Locate the server certificate in use and make note of the value in column Issued to and Issued By

    Check the certificate binding information:
    4) In the server in the Connections column on the left expand to Default Web Site
    5) Actions page click on Bindings...
    6) Site Bindings window click on https and select the Edit button
    7) Verify the SSL certificate selected in the drop down menu is the one found in step 3 above.



    Modify host values in two Web.config files located in the following location:
    [drive]:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\Applications\Trends\Web.config
     [drive]:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\Applications\AlarmConfiguration\Web.config
    8) Search for key="TrendsWebServiceHost" in the Trends  Web.config file
    9) Modify the value  to what was found in step 3. Typical this will be in the form of full computer name with domain
    10) Search for key="AlarmConfigurationHost" in the AlarmConfiguration Web.config file
    11) Modify the value  to what was found in step 3. Typical this will be in the form of full computer name with domain
    12) Reset IIS
     
    Workaround 2: Create Self-Signed Certificate
    1) Click on the Start menu, go to Administrative Tools, and click on Internet Information Services (IIS) Manager. 
    2) Click on the name of the server in the Connections column on the left. Double-click on Server Certificates. 
    3) In Actions pane click on the link Create Self-Signed Certificate and specify name for the certificate and click Ok
     
    Binding the Self-Signed Certificate:
    4) In the server in the Connections column on the left expand to Default Web Site
    5) Actions page click on Bindings...
    6) Site Bindings window click on https and select the Edit button
    7) Verify the SSL certificate selected in the drop down menu is the one created in step 3 above.
    Modify host values in two Web.config files located in the following location:
    [drive]:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\Applications\Trends\Web.config
     [drive]:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\Applications\AlarmConfiguration\Web.config
    8) Search for key="TrendsWebServiceHost" in the Trends  Web.config file
    9) Modify the value  to what was found in step 3. Typical this will be in the form of full computer name with domain
    10) Search for key="AlarmConfigurationHost" in the AlarmConfiguration Web.config file
    11) Modify the value  to what was found in step 3. Typical this will be in the form of full computer name with domain
    12) Reset IIS
     

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