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    Video: Troubleshooting no communication between UPS and PowerChute Business Edition

    Issue:
    No Communication with UPS

    Product Line:
    PowerChute Business Edition
     
    Environment:
    All supported OS

    Cause:
    There are many possible causes. See resolution / troubleshooting for list

    Resolution:

    Troubleshooting Communications on Windows

    1.     Check that the PowerChute Business Edition Agent service is running, named "APC PBE Agent".
    2.     If you are using serial communications, check a) that you are using the serial cable that came with the UPS and b) that it connects the serial port on the UPS to the serial port on your computer.
    3.     If you are using USB communications, make sure that the USB cable that came with the UPS is connected from the USB port on the UPS to the USB port on your computer.
    Note: The serial communications cable is not a standard RS-232 cable and differs depending on the UPS type. Please refer to the table below. For USB communications, the cable must be USB-IF certified.

    Choosing the DB9 or RJ45 Port
    Some UPS devices have both the DB9 and RJ45 port types (e.g. several SUA devices). If you are installing or upgrading PowerChute Business Edition with no UPS attached, and you are asked to manually choose either a DB9 or an RJ45 port: choose the DB9 port.


     
    UPS Type UPS Model Cable
    Smart-UPS All (except SMT, SMX & SURTD) 940-0024 (advanced signaling)
    940-0020 (simple signaling)
    Any standard USB cable (USB)
    Smart-UPS SMT, SMX 940-0625A (Smart Signaling)
    940-0128D (Simple Signaling)
    940-0117B (USB)
      SURTD 940-1525A (Smart Signaling)
     
    1.     With the correct cable attached, stop and restart the PowerChute Business Edition Agent service, "APC PBE Agent". If the system is still unable to communicate, proceed to the next step.
    Make sure that PowerChute Business Edition is configured to use the correct communication port.
    2.     The communication port is no longer configurable within the Agent in v9.5+. If you wish to change from a USB port to a serial port, you must re-install the PowerChute Business Edition Agent.
     

    Troubleshooting Windows Serial Communications

    Try debugging the COM port with a tool like PuTTY – using 2400 as the baud rate. See the “Checking UPS Communications on Windows” section of the PowerChute Business Edition Installation Guide for more information.


    Troubleshooting Windows USB Communications


    1.     Go to the Windows Control Panel - Administrative Tools - Computer Management.
    2.     From Device Manager select Batteries. You should see APC UPS.
    Note: If configuring for native shutdown via Control Panel - Power Options then the driver should be HID UPS Battery. Knowledge Base article FA159743 discusses how to switch drivers.
    3.     From the Device Manager select Human Interface Devices (HID). You should see a driver called American Power Conversion USB UPS. If either HID or this driver does not display, proceed with the steps below.
    4.     Make sure that the USB port is enabled in your computer BIOS. Consult your computer documentation for details on how to enable the USB Port.
    5.     If your installation includes a USB hub (a device that multiplies the number of USB ports available), and the UPS is plugged into it, check that the hub is receiving power. Check your hub's manual to learn whether the hub should be powered with an AC/DC adapter.
    6.     Ensure that the USB cable connected to the UPS is the last cable in the chain (downstream). Make sure that all other USB devices upstream from your APC UPS have communication. If an upstream device is not communicating, any device downstream possibly may not communicate either. Remove the device that is not communicating and see if that has any effect.
    7.     Using a freeware utility such as USBDeview.exe you can review all connected USB devices.
    Note: APC recommends that for optimum performance the UPSs USB cable be plugged into the PC's USB port directly, and not into a USB hub.
     

    Additional Windows Troubleshooting Information

    1.     Once you have followed the steps outlined in the Troubleshooting sections above, stop and restart the PowerChute Business Edition Agent. If the system is still unable to communicate, proceed to the next step.
    2.     If you have a SmartSlot accessory connected to the UPS, check that it is configured correctly. More information regarding these accessories is available on http://www.apc.com/products/
    3.     If you still have not established communication, try using another communications (Serial/USB) cable if one is available.
    If you have tried all of the techniques above but have still not established communication, visit http://www.apc.comhttp://www2.schneider-electric.com//support/ for troubleshooting help.

    Troubleshooting Communications on Linux

    1.   Make sure that the serial cable that came with the UPS is connected from the serial port on the UPS to the serial port on your computer. USB communications is not supported on Linux.
    2.   Stop and start the PowerChute Agent. If the Agent process is not running: start and stop it by entering the following commands in a command prompt:
    # /Linux/
    # /etc/init.d/PBEAgent start
    # /etc/init.d/PBEAgent stop
    3.   Try debugging the COM port with a tool like PuTTY – using 2400 as the baud rate. See the “Checking UPS Communications on Windows” section of the PowerChute Business Edition Installation Guide for more information.

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